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Introduction
Receipt Editor can be used to create and maintain receipt definitions for P.V. Supa software, for
example Libretto 2 and Librid 3.
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Accessing online help
Selecting Help -> Open Receipt Editor Help from the main menu or pressing F1 anywhere in the
editor opens this manual.

There is also online documentation portal available, at http://help.pv-supa.com .

http://help.pv-supa.com
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Navigating the receipt editor's user interface
Receipt editor has two views – Visual editing for editing the content and layout of the receipt and
Script Editor for writing custom functions to manipulate receipt lines’ data values.

Visual editing is divided in four sections:

Receipts (left top) contains a list of receipt definitions in the collection, grouped by languages.

Receipt elements (left bottom) contains a list of selected receipt’s sections (Header, Item and
Footer) and the lines to show on the printed receipt for each section

Receipt preview (center) shows an approximated preview of the printed receipt to help visualize
the effects of changes made in the receipt properties without actually printing the receipt after
every change

Properties (right) shows the properties of currently selected (in the bottom left section) receipt
element. The properties section is divided into sub-groups and will display different content based
on what is selected from the receipt elements:

Receipt properties provide control over the whole receipt’s appearance

Section properties for the selected section (Header/Item/Footer) provide control over that
section’s appearance

Line properties provide control for a single line’s appearance and content. This section is again
divided into sup-groups:

Label properties section for setting the text in a receipt line

Data properties section for embedding SIP fields or special functions (current date/time etc.)
in a receipt line

Line properties for controlling the appearance of the line, such as font size and alignment.

Receipt editor main window
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Opening receipt definitions from database
If database connectivity is available and database contains receipt definitions, the open dialog
pictured below is opened when the program starts. This dialog can also be accessed from the
main menu File -> Open from database or by pressing Ctrl+D anywhere in the editor.

Select the application and receipt collection you wish to open and click OK. Click Cancel to return
to the editor without opening receipt definitions from database.

Selecting software in File - Open dialog
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Saving receipt to database
If database connectivity is available, receipts can be saved by selecting File -> Save to database
in the main menu or by pressing Ctrl+S anywhere in the editor.

If the receipt collection is created from scratch or opened from an XML file, a dialog is shown (see
picture below) where the target application (for example Libretto) and receipt collection’s name
can be set.

Save to database - selecting software

If a receipt collection with the same application and name already exists in the database, a
confirmation dialog is shown. Click Yes to overwrite the existing collection with the currently open
collection. Click No or Cancel to return to the editor without saving.
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Opening receipt definitions from an XML file
Receipt definitions can be loaded from an XML file by selecting File -> Open file in the main menu
or by pressing Ctrl+O anywhere in the editor. A dialog is shown where you can select the file to be
opened. If the file does not contain valid receipt definitions, an error message is shown.
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Exporting a receipt collection to an XML file
Receipt definitions can be saved to an XML file by selecting File -> Export to file in the main
menu or by pressing Ctrl+E anywhere in the editor. A dialog is shown where the file’s path can be
set.

Export can be used to transfer receipts from one location to another, or in case there is some
reason to work on the raw XML document instead of using the editor.
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Starting a new receipt collection
A new receipt definition collection can be started by selecting File -> New receipt collection in
the main menu or by pressing Ctrl+N anywhere in the editor.
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Adding a receipt
A receipt collection needs to contain all receipts used by an application. This chapter describes
how receipts are added.

Adding a receipt with a new language
A new receipt with a new language can be added by selecting Receipt -> Add receipt with a new
language from the main menu or by pressing Ctrl+A anywhere in the editor. If there are existing
receipts, a new receipt can also be added by right-clicking an existing language in the Receipts
box (top left) and selecting Add receipt with a new language.

Next, a dialog is shown where the language of the new receipt can be selected as well as the
display name for the selected language (see picture below).

NOTE: The display name of the language can’t be changed easily so be careful not to mix
languages with incorrect names. If needed, display name of the language can be changed with a
little trick: copy the receipts to a new language, delete the misspelled language and copy the
receipts back to the original language, now correctly spelled.

Adding a receipt with new language

After selecting the language by clicking OK, a second dialog is shown where receipt’s type and
name can be set. Click OK to add the receipt or Cancel to return without creating the receipt.

Adding a new receipt - selecting receipt type



Receipt editor manual 13

Adding a receipt to an existing language
New receipts can be added to an existing language by right-clicking the target language or by
pressing Ctrl+R after selecting the language in the Receipts box (top left).

Next, a dialog is shown where receipt’s type and name can be set. Click OK to add the receipt or
Cancel to return without creating the new receipt.

Add a new receipt to existing language
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Copying a receipt to another language
A receipt can be copied to another language by right-clicking the target language or by pressing 
Ctrl+C after selecting the language in the Receipts box (top left). This could be used for example
to create a copy in a nearby language, such as US english to UK english.

When copying, a dialog is shown where receipt’s language and name can be set. Click OK to add
the receipt or Cancel to return without creating the new receipt.
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Deleting receipts
Receipts can be deleted from receipt collection, either single receipts or all receipts in a selected
language (i.e. deleting the whole language).

Deleting a single receipt
A receipt can be deleted by right-clicking the receipt you wish to delete and selecting Delete
receipt or by pressing Delete key after selecting the receipt in the Receipts box (top left). A
confirmation dialog is shown. Answering Yes deletes the receipt and answering No returns to the
editor without deleting

Deleting all receipts of a given language
All receipts of a given language can be deleted by right-clicking the language to be deleted and
selecting Delete language and all its receipts or by pressing Delete key after selecting the
language in the Receipts box (top left). A confirmation dialog is shown. Click Yes to delete all
receipts of the given language or No to return to the editor without deleting
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Adding, moving and deleting receipt lines
This chapter explains how to work on individual lines on receipts.

Adding a new line above the selected line
A new line can be added by right-clicking the target section (Header, Item or Footer) or by
pressing Ctrl+L after selecting the section in the Receipt elements box (bottom left).

Adding a new line to receipt
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Inserting a new line above the selected line
A new line can be added above the selected line by right-clicking the existing line or by pressing
Ctrl+I after selecting the line in the Receipt elements box (bottom left).

Inserting a new line to receipt

Moving lines up or down in the section
A line that is not at the top of its containing section (Header, Item or Footer) can be moved up
within the section by right-clicking the line and selecting Move line up or by pressing Ctrl+Up
arrow after selecting the line in the Receipt elements box (bottom left).

A line that is not at the bottom of its containing section can be moved down within the section by
right-clicking the line and selecting Move line down or by pressing Ctrl+Down arrow after
selecting the line in the Receipt elements box (bottom left).

Deleting a line
A line can be deleted by right-clicking the line you wish to delete and selecting Delete line
element or by pressing Delete key after selecting the line in the Receipt elements box (bottom
left).
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SIP fileds and current date/time
SIP-fields can be embedded in Item section’s lines. Built-in shortcuts can be accessed by right-
clicking the Value field in Item line’s Data properties view (see picture below). Any SIP field can
also be manually written in the Value field in the format {SIP:XX} (replace XX with the SIP field’s
ID).

NOTE: surrounding brackets “{“ and “}” are obligatory for SIP fields and functions.

Current date and time can be embedded in any line, but SIP fields are relevant only in the Item
section’s lines.

Working with SIP fields
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Manipulating data values with functions
Data values can be manipulated with built-in functions as well as custom functions written in the
Script Editor (see chapter Script Editor ). Receipt Editor contains three built-in functions:
DashMask, GetDayFromToday and Weekday. Available functions are accessed by right-clicking
in the Data properties field “Script method". Functions and their parameters can be edited
manually in the “Script method” field.

Working with Script methods

When opening a receipt definition from file or database and a script is embedded with the
receipts, Receipt Editor compiles the script automatically. User-defined functions appear in the
menu after compiling the script in Script Editor.

22
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Printing the selected receipt
Currently selected receipt can be printed by selecting File -> Print in the main menu or by
pressing Ctrl+P anywhere in the editor. A standard printer selection dialog is shown where you
can choose the target printer. Click Print to start printing or Cancel to return to the editor without
printing.

Two-column printing
Two-column printing can be achieved by checking Use columns in Receipt properties and
checking Page/column break in Line properties of the first line to be on the second column. Page
orientation (portrait/landscape) can be set in Receipt properties.

Printing on two pages
Printing on two pages can be achieved by unchecking Use columns in Receipt properties and
checking Page/column break in Line properties of the first line to be on the second page. Page
orientation (portrait/landscape) can be set in Receipt properties.
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Closing receipt editor
Receipt Editor can be closed by selecting File -> Close Receipt Editor in the main menu or by
pressing Alt+F4 anywhere in the editor. If there are unsaved changes, a confirmation dialog is
shown. Names of all receipts that have unsaved changes are listed here. Click Yes to save the
changes before closing or No to discard the changes. Click Cancel to return to the editor.
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Script editor
Script editor can be used to write custom functions of formatting or manipulating Data values in
receipt lines. Script language is C#. Functions have a few restrictions:

· last parameter must be of type string

· return value must be string

· public & static

Script editor
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